If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Search found 17 matches

by Texas122
Wed Oct 07, 2015 8:54 am
Forum: 2010-newer Ford Taurus (6th Generation)
Topic: Time for tires
Replies: 2
Views: 555

Time for tires

2013Taurus SEL is ready for tires after only 28,000 miles. Need 235/55R18...any suggestions or experience for best mileage warranty and ride.

Thanks

Texas122
by Texas122
Tue Sep 08, 2015 6:26 am
Forum: Under the Hood
Topic: 2013 SEL losing power
Replies: 32
Views: 3566

Re: 2013 SEL losing power

Gloriawright At the Ford Area Service Managers suggestion, I bought the car to a different dealership. They uncovered an error code and replaced the throttle body. No explanation was given why the initial dealership could not troubleshoot. Until resolved, it was both frustrating and scary. Luckily f...
by Texas122
Mon Aug 31, 2015 6:34 am
Forum: 2010-newer Ford Taurus (6th Generation)
Topic: 2013 SEL door handle recall
Replies: 8
Views: 3309

Re: 2013 SEL door handle recall

Door handle finally arrived. Replacement scheduled for Sept. 2nd.
by Texas122
Mon Jul 27, 2015 1:28 pm
Forum: 2010-newer Ford Taurus (6th Generation)
Topic: 2013 SEL door handle recall
Replies: 8
Views: 3309

Re: 2013 SEL door handle recall

Anyone get the recalled handle yet? Driver side door opened a couple of times this weekend while driving. Didn't realize inside handle didn't return and latch after opening. Ford really should have had parts available before ordering a recall. Now this is getting dangerous.

Thanks

Texas122
by Texas122
Thu Jul 02, 2015 6:53 am
Forum: 2010-newer Ford Taurus (6th Generation)
Topic: 2013 SEL door handle recall
Replies: 8
Views: 3309

2013 SEL door handle recall

Dropped our 2013 SEL at dealership for broken inside door handle. A recall notice was issued in March 2015. They held the car all day and called early evening to inform me the handle was on back order and were unsure when they would arrive. Anyone else having similar issue. It is a real pain to open...
by Texas122
Thu Jan 22, 2015 2:01 pm
Forum: Under the Hood
Topic: 2013 SEL losing power
Replies: 32
Views: 3566

Re: 2013 SEL losing power

Greetings, After no trouble found at nearby ford dealership, decided to drop the car off at a dealership 45 minutes away. ( thanks ford for providing a loaner vehicle) Well, this dealership found an error code and replaced the throttle body. Ford engineers were involved. Although I am grateful, I am...
by Texas122
Thu Jan 15, 2015 11:48 am
Forum: Under the Hood
Topic: 2013 SEL losing power
Replies: 32
Views: 3566

Re: 2013 SEL losing power

Dropped car at ford this morning. Unfortunately, they are asking me the same questions as back in August and referring to no codes recorded in car computer. Don' t understand why they can't refer to car maintenence history. Not a lot of confidence this will be correctly analyzed today.
by Texas122
Sun Jan 11, 2015 10:44 am
Forum: 2010-newer Taurus SHO
Topic: 2013 Sho Problems
Replies: 5
Views: 2677

Re: 2013 Sho Problems

Greetings,

Passenger seat cover unclipped on my 2013 Taurus SEL. Dealer added additional clips. Problem resolved for now

Texas122
by Texas122
Sun Jan 11, 2015 10:33 am
Forum: Under the Hood
Topic: 2013 SEL losing power
Replies: 32
Views: 3566

Re: 2013 SEL losing power

Greetings again, Well, my problem has returned. New battery in September had resolved the "cut out" problem, but it returned yesterday. No acceleration and the wrench indicator came on. Turned car off and restarted and all was well again. I suspect something is draining the battery. Thanks for any t...
by Texas122
Sun Jan 11, 2015 10:27 am
Forum: 2010-newer Ford Taurus (6th Generation)
Topic: 2014 Taurus Lmtd suddenly quits w/o warning
Replies: 6
Views: 730

Re: 2014 Taurus Lmtd suddenly quits w/o warning

I am having this same problem with 2013 Taurus SEL. Back in September they replaced the battery and all was well until yesterday. Problem is back. I will be dropping the car off at Ford tomorrow. Can't believe I have two bad batteries. Something is draining it.
by Texas122
Fri Sep 05, 2014 10:44 am
Forum: Under the Hood
Topic: 2013 SEL losing power
Replies: 32
Views: 3566

Re: 2013 SEL losing power

Got the car back yesterday. Here is what Ford reported: Replaced battery due to low CCA at 80 rating 650 Reprogrammed PCM to latest Calibration Backup camera had to be special ordered. Did not to a comprehensive explanation from service rep. Obviously they still do not know why the car is losing acc...
by Texas122
Wed Sep 03, 2014 7:22 pm
Forum: Under the Hood
Topic: 2013 SEL losing power
Replies: 32
Views: 3566

Re: 2013 SEL losing power

Thanks to Deysha at ford service, Ford engineers have stepped in. Dealership called this PM, battery and backup camera need to be replaced. I doubt this is a solution, but they are continuing to work with the engineers, and will start on power and acceleration issues tomorrow.
by Texas122
Wed Sep 03, 2014 5:24 pm
Forum: Under the Hood
Topic: 2013 SEL losing power
Replies: 32
Views: 3566

Re: 2013 SEL losing power

Interesting you mention radio, the speakers have cut out periodically. Electrical issues are building up
by Texas122
Wed Sep 03, 2014 10:28 am
Forum: Under the Hood
Topic: 2013 SEL losing power
Replies: 32
Views: 3566

Re: 2013 SEL losing power

UPDATE: The Taurus still cuts out with no acceleration. However, the backup camera is again not working and it is difficult to start the car. Very slow crank, need to depress the start button four or five times before it turns over. Thinking I may have an electrical issue that is causing all this. T...
by Texas122
Fri Aug 29, 2014 2:46 pm
Forum: Under the Hood
Topic: 2013 SEL losing power
Replies: 32
Views: 3566

Re: 2013 SEL losing power

Well as luck has it, ford had the car for 2 days and couldn't recreate the problem, but it returned this afternoon. Luckily, it was on a city street and not the highway. I suspect I will return to the dealership on Tuesday and inquire further about the flight recorder.
by Texas122
Fri Aug 29, 2014 4:36 am
Forum: Under the Hood
Topic: 2013 SEL losing power
Replies: 32
Views: 3566

Re: 2013 SEL losing power

Thanks for the reply. As I expected, they could not recreate the problem, nor did they have a flight recorder as suggested. I asked about throttle body, which was a problem on my daughters 2011 Fusion, but they indicated it was not a known problem with the Taurus. Not pleased with the " let's hope i...
by Texas122
Thu Aug 28, 2014 6:41 am
Forum: Under the Hood
Topic: 2013 SEL losing power
Replies: 32
Views: 3566

2013 SEL losing power

Greetings, new to this site. Twice within the past seven days, our 2013 Taurus sel lost power while driving. Wrench icon illuminated and lost acceleration. Engine was still running, all electrical was working. Coasted to a stop, turned off engine for a minute, restarted and all was good. Yesterday, ...