If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Search found 5 matches

by Voltaire00
Wed Feb 21, 2018 10:32 pm
Forum: Ford Police Interceptor 2013-newer
Topic: Idle hours - is this high? 2013 PI sedan
Replies: 6
Views: 1514

Idle hours - is this high? 2013 PI sedan

Hello all, I was curious the other day and looked at my 2013 PIs idle hours and it currently has about 6500 hours, 9450 engine hours with 66,000 miles. I feel that this is pretty high for idle hours, but is there anyone with higher idle hours? Vehicle drives smooth and nothing appears abnormal. Anyt...
by Voltaire00
Wed Jan 03, 2018 3:17 pm
Forum: Ford Police Interceptor 2013-newer
Topic: OEM Taurus Console Questions - for PI install
Replies: 17
Views: 2076

Re: OEM Taurus Console Questions - for PI install

there is a harness pack you can buy to help wire your civi console. it plugs into two of the existing PIS empty harnesses under the center dash and each lead has the function of that wire (always hot/door open/ignition on, etc.) with these, you can easily decide how to best connect your civi consol...
by Voltaire00
Wed Jan 03, 2018 8:22 am
Forum: Ford Police Interceptor 2013-newer
Topic: OEM Taurus Console Questions - for PI install
Replies: 17
Views: 2076

Re: OEM Taurus Console Questions - for PI install

The two 12 volts connectors will not match up to any connectors to the car. So yeah you will have to tap into the police harness.

Yes, it will be in the dash already. Good luck!
by Voltaire00
Sun Dec 31, 2017 11:13 pm
Forum: Ford Police Interceptor 2013-newer
Topic: OEM Taurus Console Questions - for PI install
Replies: 17
Views: 2076

Re: OEM Taurus Console Questions - for PI install

1) For the rear ducts they should be already in the console that you bought. There is a factory duct already in the car that is covered up and when you install the console it just slides in. 2) I removed the metal plate on mine. There should be bolts that line up with the console and the console is ...
by Voltaire00
Mon Oct 09, 2017 7:21 pm
Forum: Ford Police Interceptor 2013-newer
Topic: 2013 PI radio issues
Replies: 13
Views: 2219

Re: 2013 PI radio issues

You may want to check the lose wires in the car. Some police departments use the speakers for the radio and since you say it happens when you start the car a wire might be shorting out somewhere. That's my only idea.