If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Heater Hose Fitting by the thermostat 1999

Post Reply
bamboozer
New Member
Posts: 3
Joined: Sat Sep 17, 2016 2:16 pm
Vehicle: 1999 taurus se wagon

Heater Hose Fitting by the thermostat 1999

Post by bamboozer » Mon Nov 26, 2018 12:05 pm

Like everybody else the cooling system remains a problem on my 1999 Taurus, had a minor coolant leak, when I removed the heater hose the metal tube that comes out of the fitting came with it, completely rusted. The fitting has two sensors in it, they were easy to remove, but the fitting itself does not seem to be screwed in. I can turn it with effort, but it does not seem to be unscrewing. Sadly I don't have a picture but will try to get one. As noted it's behind the thermostat housing.


bamboozer
New Member
Posts: 3
Joined: Sat Sep 17, 2016 2:16 pm
Vehicle: 1999 taurus se wagon

Re: Heater Hose Fitting by the thermostat 1999

Post by bamboozer » Mon Nov 26, 2018 4:53 pm

I got a few pictures, hope this helps.
IMG_1982.JPG
IMG_1982.JPG (83.84 KiB) Viewed 819 times
Attachments
IMG_1980.JPG
IMG_1980.JPG (80.37 KiB) Viewed 819 times

bamboozer
New Member
Posts: 3
Joined: Sat Sep 17, 2016 2:16 pm
Vehicle: 1999 taurus se wagon

Re: Heater Hose Fitting by the thermostat 1999

Post by bamboozer » Mon Nov 26, 2018 4:55 pm

The second picture shows where the fitting is attached to the engine, difficult to turn despite penetrating oil it does not seem to be screwing out, but I could be wrong. Not shown is where the two sensors screw into the fitting.

Post Reply