If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

2008 Taurus SEL Speedometer problem

Post Reply
nnothing
New Member
Posts: 1
Joined: Fri Dec 01, 2017 3:21 am
Vehicle: 2008 Ford Taurus SEL

2008 Taurus SEL Speedometer problem

Post by nnothing » Fri Dec 01, 2017 3:34 am

I have a 2008 Taurus and have had this problem with it for years and have just dealt with it, but I wonder if there might be a fix. The speedometer is accurate, but the needle has fallen to 20 mph below where it should be, so when the car isn't moving the needle sits pointing almost straight down. As the car accelerates it's consistently 20 mph off as tested with gps and street radar signs.


Jerry Leighton
New Member
Posts: 4
Joined: Sat Jan 06, 2018 1:34 am
Vehicle: 2008 SEL AWD

Re: 2008 Taurus SEL Speedometer problem

Post by Jerry Leighton » Sat Jan 06, 2018 1:40 am

Hello Fellow Taurus club members!
My name is Jerry Leighton and I am new here and I have a 2008 Taurus AWD SEL with 121,889 miles. I love my car and it has been pretty trouble free for the 6 years I have owned it. However today I drove my car and realized that the speedometer onmy vehicle is also not functioning correctly. The Tach is also not right. When the engine is turned off the speedo reads about 20 MPH BELOW zero and the tach reads 600 RPM. When I am driving on the freeway the speedo reads 40 MPH and I am really going about 65 MPH according to my GPS device. I realized this when I was driving very fast at what I thought was 60 MPH when it turns out I was really going over 85 MPH!
I am hoping to tap into the collective Taurus mind hive here to see if you all may know what is wrong with my car and how I can go about fixing it. This literally happens today and before that this issue was not showing itself to me. I am pretty mechanically inclined so I am hoping all I need to do is remove the instrument cluster and make some sort of adjustment. I tried disconnecting and re-connecting the battery and this did nothing. Thanks in advance for your help
-Jerry

Jerry Leighton
New Member
Posts: 4
Joined: Sat Jan 06, 2018 1:34 am
Vehicle: 2008 SEL AWD

Re: 2008 Taurus SEL Speedometer problem

Post by Jerry Leighton » Tue Jan 09, 2018 1:28 pm

Hello Folks,
I fixed my car last night. The solution was as follows: I removed the instrument cluster and removed the clear plastic cover to expose the gauges. I gently removed the needle from the speedometer and form the tach and re installed them in the zero position by gently pressing them back into place. I then re-installed the cluster to the dash and tested it. The Speedometer now works perfectly as confirmed by the GPS Speedometer app on my smart phone.
I have a theory as to why this happened in the 1st place. I had tapped the dash with my hand previously in an attempt to get a dash light bulb to work. In doing so the vibration moved the needle on the gauges. So even goign over a speed bump could cause this in theory. Ford did not design these gauges whit a little stop posit at the zero setting to there is nothing to prevent the needle from moving below zero.
-Jerry

Post Reply